Arbitrum Blockchain Down
Incident Report for Rise Works
Postmortem

Arbitrum sequencer crashed due to high demand and new transactions weren’t being included in blocks. Rise’s Arbitrum nodes were idle until sequencer was back online.

Posted Mar 03, 2024 - 18:05 UTC

Resolved
Blockchain infrastructure systems and transactions have returned to a normal state.
Posted Dec 15, 2023 - 22:27 UTC
Update
Arbitrum blockchain is up and running again but with very high transaction costs. We're actively monitoring transactions for costs to return to normal.
Posted Dec 15, 2023 - 20:33 UTC
Monitoring
Arbitrum blockchain is up but unstable. We're continuing to monitor and we will activate the site as soon as things are stable. More details can be found here. https://status.arbitrum.io/clq6te1l142387b8n5bmllk9es
Posted Dec 15, 2023 - 15:45 UTC
This incident affected: Website, Pay Remittance, Deposits, Pay API, and Infura Arbitrum Mainnet.